Cant instalt jekyll bundler - windows 10


#1

INTRO
well hi everybody,

I have been trying to install Jekyll using rubyinstaller, chocolatey, github pages via chocolatey
following the Jekyll web documentation and tried also with a nice video tutorial - but every time getting some error in my cmd.

PROBLEM
last time i tried using the rubyinstaller , when writing on cmd “jekyll new blogname” it says
"Could not load Bundler. Bundle install skipped."

so i go back and write "gem install jekyll bundler"
and i get:

ERROR: Could not find a valid gem ‘jekyll’ (>= 0), here is why:
Unable to download data from https://rubygems.org/ - SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (LINKrubygemsDOTORG/specs.4.8.gz)
ERROR: Could not find a valid gem ‘bundler’ (>= 0), here is why:
Unable to download data from https://rubygems.org/ - SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (CANTINSERTLINK/specs.4.8.gz)

I don’t really want to give up, please help :slight_smile:


#2

I run jekyll on win 10 no problem.

I would uninstall and start over - how did you install ruby? with this?:

https://rubyinstaller.org/

There should not be any need for choclatey- what did you use it to install?

the error has something to do with a certificate mis-match. I vaguely remember seeing it somewhere for something else, but it should not be a problem for jekyll.

Did you add the path to ruby into your path variable?


#3

@rdyar

yes, i have installed ruby using rubyinstaller.
how do i unistall everything i did? (ruby, jekyll, and gem)

Did you add the path to ruby into your path variable?* List item

no, i don’t even know what this means


#4

what did you use choclatey for?

I don’t think you would have received the error if the path wasn’t in there, its possible something added it for you but usually you have to do it manually…

I’m no expert so this may not be entirely correct:

When you use something like ruby that runs at the command prompt, it will work only in the directory where that executable is - so if you install ruby to c:/ruby, and you are in that directory then ruby commands might work from the command line cause the executable is there also. But normally you would want the command prompt to be able to access those commands no matter where you are - so you add the path to the executable to your environment variable. Then the command window knows how to execute the commands no matter where you are.

To do this, right click on This PC in file manage, then Properties >> Advanced System Settings >> Environment Variables and then you will see both system variables and user variables - I use system variables but I think either would work. Then double click on Path and you will see a list of things - see if one of them is a path to ruby/bin, if not add it in.

To be more precise my path for ruby is: C:\Ruby22-x64\bin - this is the line highlighted below.

This was all a mystery to me for quite a while, now I sort of get what is going on.

The error you get looks like ruby is working, so the path may not be your problem. But I would double check it and make sure the path is correct, maybe choclatey did something and there are 2 and it is using something that doesn’t work?


#5

This error means that your system is not able to connect to Rubygems.org securely. You can try installing a new version of rubygems manually using the instructions towards the bottom of the page at https://rubygems.org/pages/download

Try running gem install bundler when you finish updating Rubygems.
If things still don’t work, then you’ll have to manually add a certificate to your system by following the instructions in this StackOverflow answer


#6

ruby wasn’t in the list so I added but didn’t fix the problem.

I am going to try a new installation ASAP