Can't create a new/test site w/Jekyll


#1

When I get to the stage of jekyll new awesome-site it is throwing this error.

jekyll new awesome-site
/Users/todd/.rvm/gems/ruby-2.3.3/gems/bundler-1.16.3/lib/bundler/runtime.rb:313:in `check_for_activated_spec!': You have already activated i18n 0.9.5, but your Gemfile requires i18n 1.0.1. Prepending `bundle exec` to your command may solve this. (Gem::LoadError)
from /Users/todd/.rvm/gems/ruby-2.3.3/gems/bundler-1.16.3/lib/bundler/runtime.rb:31:in `block in setup'
from /Users/todd/.rvm/gems/ruby-2.3.3/gems/bundler-1.16.3/lib/bundler/runtime.rb:26:in `map'
from /Users/todd/.rvm/gems/ruby-2.3.3/gems/bundler-1.16.3/lib/bundler/runtime.rb:26:in `setup'
from /Users/todd/.rvm/gems/ruby-2.3.3/gems/bundler-1.16.3/lib/bundler.rb:107:in `setup'
from /Users/todd/.rvm/gems/ruby-2.3.3/gems/jekyll-3.8.3/lib/jekyll/plugin_manager.rb:50:in `require_from_bundler'
from /Users/todd/.rvm/gems/ruby-2.3.3/gems/jekyll-3.8.3/exe/jekyll:11:in `<top (required)>'
from /Users/todd/.rvm/gems/ruby-2.3.3/bin/jekyll:23:in `load'
from /Users/todd/.rvm/gems/ruby-2.3.3/bin/jekyll:23:in `<main>'
from /Users/todd/.rvm/gems/ruby-2.3.3/bin/ruby_executable_hooks:15:in `eval'
from /Users/todd/.rvm/gems/ruby-2.3.3/bin/ruby_executable_hooks:15:in `<main>'

I’ve tried searching around for an answer and haven’t been able to find one. Thanks. :slight_smile:


#2

Give that line’s advice a try:

bundle exec jekyll new awesome-site

#3

No dice.

bundle exec jekyll new awesome-site
/Users/todd/.rvm/gems/ruby-2.3.3/gems/bundler-1.16.3/lib/bundler/rubygems_integration.rb:462:in `block in replace_bin_path': can't find executable jekyll for gem jekyll. jekyll is not currently included in the bundle, perhaps you meant to add it to your Gemfile? (Gem::Exception)
from /Users/todd/.rvm/gems/ruby-2.3.3/gems/bundler-1.16.3/lib/bundler/rubygems_integration.rb:482:in `block in replace_bin_path'
from /Users/todd/.rvm/gems/ruby-2.3.3/bin/jekyll:23:in `<main>'
from /Users/todd/.rvm/gems/ruby-2.3.3/bin/ruby_executable_hooks:15:in `eval'
from /Users/todd/.rvm/gems/ruby-2.3.3/bin/ruby_executable_hooks:15:in `<main>'

I’ll keep digging around the forum and internet. Thanks for the help @mmistakes :slight_smile:


#4

Maybe try gem update bundler then gem update jekyll to make sure you’re on the latest.

Other than that it’s probably some issue with your Ruby environment. Which is always the most painful thing about getting Jekyll up and running.


#5

Yeah, it’s looking to be my Ruby environment. Now to take the weekend (hopefully not) to figure it out and clean it up. Thanks.


#6

This worked and I was able to create the test site with jekyll if anyone needs any ideas if they run into the same issues I did…

bundle add jekyll