Struggling to build site

Hello

I would greatly appreciate help in building this site. I am getting so many errors and permission denied messages and have been trying all of the ways comments I find on google suggest to fix the issue to no avail.

Can anyone help run through these problems?

Thanks.

can you post the errors? and a link to the repo?

Hi there,

Apologies for my slow reply!!

What is a link to the repo?

The errors are like this;

sam$ gem install bundler jekyll
ERROR: While executing gem … (Gem::FilePermissionError)
You don’t have write permissions for the /Library/Ruby/Gems/2.3.0 directory.
samuels-MacBook-Pro:~ sam$

Basically, no matter what I do… I keep running into ‘permission errors’ on the command line.

I tried it out on a new admin profile on my mac but it said the same thing. I’m running the latest MacOS software.

I had a go at making a jekyll site last year on the older MacOS and it worked so I don’t know why I can’t do it now.

Did you try running the command as sudo ?

sudo gem install bundler jekyll