Strange Webrick exception

I get this exception pretty consistently every time my site rebuilds

[2019-01-21 18:15:06] ERROR Errno::ECONNRESET: Connection reset by peer @ io_fillbuf - fd:18
    /Users/mitchell/.asdf/installs/ruby/2.4.1/lib/ruby/2.4.0/webrick/httpserver.rb:82:in `eof?'
    /Users/mitchell/.asdf/installs/ruby/2.4.1/lib/ruby/2.4.0/webrick/httpserver.rb:82:in `run'
    /Users/mitchell/.asdf/installs/ruby/2.4.1/lib/ruby/2.4.0/webrick/server.rb:290:in `block in start_thread'

I think this might be caused by a plugin I’m using (jekyll-postcss), but I’m not really clear as to why that would be happening.

I run my site with bundle exec jekyll serve --livereload --drafts --future --port 5000

Any ideas?

Thanks!

Do you get the same error without the plugin? When you omit to specify a custom port?

@mitchhanberg, I’m getting the same errors, have you been able to resolve it?

No, but I haven’t put any thought into figuring it out since it doesn’t seem to have affect my development progress.

PS Sorry this response took a while.