Post doesn't show up according to theirs date


I don’t know, if all of you have noticed this problem.

But I have

I have tested this on different platforms like on Github, Netlify and on a server too.

If we use Github, then it shows all the blog post, even if we add the future date in the blog post.

If we use Netlify or any other service (where _site directory is used by servers) then if we publish a blog now and add the today’s date in the yaml data, then the blog shows up after two days.

I hope, you have understood what I am trying to say


Could be a difference in the timezone. Trying setting it in your _config.yml


That’s really strange actually, because when you upload contents of _site to the remote host (incl. GitHub Pages), the site is no longer within Jekyll’s scope… The site is now completely static by all standards.


I know, that’s really strange.

But is happening.


How to add timezone in the front matter


Like this? +0530.

If we have the time zone of UTC+05:30


yep… date: 2017-11-24 09:00:00 +0530


@mmistakes, I think there should be an update in the documentation that if we do not have timezone Jekyll will take certain value by default, which may affect the way post appear on your website depending upon the time.

But I am not sure what is the default timezone that Jekyll uses if we don’t give a timezone value.


The default timezone is your system’s timezone


Nope. That is not possible because I can understand if I am working locally by running a local server.

But it should not affect the post if it hosted on the server (github) and if the posts are hosted on github then i think there is no relation between my local machine system timezone and the jekyll’s default timezone.


:slight_smile: When the site is built on GitHub Pages, the timezone defaults to the timezone configured in GitHub servers


It means the timezone changes depending upon the server, where we host. Right?


In theory, yes. I’ve not tested it, though.
To overcome this probable issue, Jekyll recommends setting the timezone in your config file:

# _config.yml

timezone: Asia/Kolkata


so @ashmaroli isn’t it is a good idea to mention this thing in the documentation also.


Feel free to submit a PR at GitHub if you feel the info provided in the table is inadequate


I have created the pull request for the same.