Please append `--trace` to the `build` command

Hi, I have tried to fix the below error but I’m unable to find any help.

Jekyll 4.3.2 Please append --trace to the build command for any additional information or backtrace.

/opt/hostedtoolcache/Ruby/3.2.2/x64/lib/ruby/3.2.0/psych/parser.rb:62:in `_native_parse’: (/home/runner/work/ did not find expected key while parsing a block mapping at line 4 column 1 (Psych::SyntaxError)

line 4 column 1 | can’t see any error.
theme: jekyll-theme-chirpy

Error: Process completed with exit code 1.


I can’t get to fix it.

Thanks for the help.

can you post a link to the repo?



hmm, there is a .nojekyll file in there, so I guess you are building via the action? are you getting this error locally? or from GH?

I would try removing some of the lines in the config file to try and troubleshoot it - I am not so sure line 4 is that line you have, it may skip commented lines or something.

when a run: bundle exec jekyll serve

jekyll 4.3.2 | Error:  (C:/ did not find expected key while parsing a block mapping at line 4 column 1
C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/safe_yaml-1.0.5/lib/safe_yaml/load.rb:143:in `parse': (C:/ did not find expected key while parsing a block mapping at line 4 column 1 (Psych::SyntaxError)
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/safe_yaml-1.0.5/lib/safe_yaml/load.rb:143:in `load'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/safe_yaml-1.0.5/lib/safe_yaml/load.rb:157:in `block in load_file'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/safe_yaml-1.0.5/lib/safe_yaml/load.rb:157:in `open'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/safe_yaml-1.0.5/lib/safe_yaml/load.rb:157:in `load_file'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/jekyll-4.3.2/lib/jekyll/configuration.rb:129:in `safe_load_file'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/jekyll-4.3.2/lib/jekyll/configuration.rb:167:in `read_config_file'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/jekyll-4.3.2/lib/jekyll/configuration.rb:198:in `block in read_config_files'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/jekyll-4.3.2/lib/jekyll/configuration.rb:195:in `each'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/jekyll-4.3.2/lib/jekyll/configuration.rb:195:in `read_config_files'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/jekyll-4.3.2/lib/jekyll.rb:118:in `configuration'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/jekyll-4.3.2/lib/jekyll/command.rb:44:in `configuration_from_options'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/jekyll-4.3.2/lib/jekyll/commands/serve.rb:83:in `block (2 levels) in init_with_program'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in `block in execute'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in `each'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in `execute'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/mercenary-0.4.0/lib/mercenary/program.rb:44:in `go'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/mercenary-0.4.0/lib/mercenary.rb:21:in `program'
        from C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/jekyll-4.3.2/exe/jekyll:15:in `<top (required)>'
        from C:/Ruby27-x64/bin/jekyll:23:in `load'
        from C:/Ruby27-x64/bin/jekyll:23:in `<main>'

same error

comment out line 4 and see if it still says the same thing.

I think you either have some bad yaml in there somewhere or perhaps the thing that parses the yaml is not correct - if you search (Psych::SyntaxError) you’ll see an issue for ruby on rails where that was the issue - the parser need an update or something.

Thanks for the help… updating ruby

let you know if the updated fix the issue.

Thanks again