Livereload plugin issue with eventmachine gem


I’m having an issue getting up and going with livereload. It’s having an issue with eventmachine. I tried adding it to my gemfile but that doesn’t seem to make a difference. Can you tell what I am missing?

I just updated my jekyll image docker pull jekyll/jekyll:pages

I tried it with the jekyll/jekyll image and then it says that --livereload is an invalid option.


source ''
group :plugins do
    gem 'jekyll'
    gem 'liquid_reading_time'
    gem 'liquid_pluralize'
    gem 'eventmachine'
    gem 'jekyll-livereload'


livereload: true
reload_port: 35729


version: "2"

    container_name: ""
    image: "jekyll/jekyll:pages"
    command: "jekyll serve --watch --incremental"
      - "./:/srv/jekyll"
      - ""

Terminal | continue. | Make sure that `gem install eventmachine -v '1.2.5'` succeeds before bundling. | | In Gemfile: |   jekyll-livereload was resolved to 0.2.2, which depends on |     em-websocket was resolved to 0.5.1, which depends on |       eventmachine```


Try installing just eventmachine first…

gem install eventmachine -v '1.2.5'

If it fails, post the entire error message here…
If that succeeds, your usual Jekyll workflow should mpst probably work fine.