Jekyll spawned from another process inside docker

Hi all -

Has anyone experienced issues with running Jekyll, when spawned as a subprocess inside a docker container. The peculiar thing is that there are no issues when running locally, but when doing the exact same thing inside docker, Jekyll simply hangs at a certain point.

do you get an error? what is the command you are using to spawn it? The command I believe is different depending on your OS.

Does it actually run and then stop or doesn’t even run?

It is spawned from the Java process that is set as the entrypoint of the container. I get no errors from Jekyll, it simply hangs. When attaching to the container I can see both processes are running (Java and Jekyll). It is spawned from within the Java process using the Apache executor framework (org.apache.commons.exec.DefaultExecutor). The following is used for execution:

org.apache.commons.exec.CommandLine.parse(jekyllCommand+" build --destination \""+outputDir+"\""), where jekyllCommand is simply jekyll

The java process does pre-processing and post-processing for Jekyll, and launches it through the command line. Jens (who reported this), and I can both run exactly the same inputs and outputs outside Docker, and it runs fine. There’s no errors from Jekyll outside docker. Jens - what version of Jekyll are you using?

I maintain the Java code which is here: Jens is trying to get it working under docker (it used to work but now does not)

Does Jekyll run on JRuby? that’s one possible thing for us to try

Ive tried running on jruby as well. Same resultat. Ive tried Jekyll in different versions (3.8.5, 3.8.6, 4.0.0)

Oops - jvitrifork is also me