Jekyll-paginate-v2 not work with Jekyll v4

Dependency Error:

Yikes! It looks like you don’t have jekyll-paginate-v2 or one of its dependencies installed. In order to use Jekyll as currently configured, you’ll need to install this gem. If you’ve run Jekyll with bundle exec, ensure that you have included the jekyll-paginate-v2 gem in your Gemfile as well. The full error message from Ruby is: ‘Unable to activate jekyll-paginate-v2-2.0.0, because jekyll-4.0.0 conflicts with jekyll (~> 3.0)’ If you run into trouble, you can find helpful resources at https://jekyllrb.com/help/!

Help!:sleepy:

The support has been added but there hasn’t been a release. So edit your Gemfile to:

gem 'jekyll-paginate-v2', github: 'sverrirs/jekyll-paginate-v2'
1 Like

I do not use gemfile.
Can i install differently?

example: "sudo gem i 'jekyll-paginate-v2', github: 'sverrirs/jekyll-paginate-v2"

To install the gem from GitHub without a Gemfile, you’ll have to manually build the gem from the repository yourselves and install that:

  1. Clone the repository locally and move into the directory:
    git clone https://github.com/sverrirs/jekyll-paginate-v2.git
    cd jekyll-paginate-v2
    
  2. Bump version in lib/jeyll-paginate-v2/version.rb
  3. Build the gem
    gem build jekyll-paginate-v2.gemspec
    
  4. Install the gem you just built:
    gem install jekyll-paginate-v2 --local
    
1 Like

Thank you very much!:+1:

1 Like