Jekyll and Monterey

Hi everyone,
Since updating to Mac OS 12.0.1 I cannot get Jekyll to work.
I have reinstalled ruby and followed the instructions on But when I run Jekyll serve I get a Could not find event machine-1.2.7 in any of the sources. Running bundle install as suggested after the warning does not solve the problem.

Can anyone help?
Thank you so much.

What error do you get when you simply run:

gem install eventmachine --user-install

Hi there, this is what I get:

WARNING:  You don't have /Users/steph/.gem/ruby/3.0.0/bin in your PATH,
          gem executables will not run.
Building native extensions. This could take a while...
Successfully installed eventmachine-1.2.7
Parsing documentation for eventmachine-1.2.7
Done installing documentation for eventmachine after 0 seconds
1 gem installed

I guess ruby not being in “my PATH” is the issue because when I try to run the serve function I still get the same error message: can’t find eventmachine.

Do you know how to fix that?

The error is telling you to add to PATH, so do that like this.

echo 'export PATH="$HOME/.gem/ruby/3.0.0/bin:$PATH"' >> ~/.zshrc

# If you're using Bash
echo 'export PATH="$HOME/.gem/ruby/3.0.0/bin:$PATH"' >> ~/.bash_profile

Depending on if you use ZSH or Bash.

Based on

BTW I don’t bother with bash profile, .bashrc is good enough for me.

And remember to start a new terminal to get the PATH changes

Thanks Michael but I did that already, it is in the install instructions on which I have followed to a tee.

I’ll do a clean install of Monterey and start from scratch because this is driving me nuts.

Check these two things

event machine exists here

ls .gem/ruby/3.0.0/bin

This is your path .gem/ruby/3.0.0/bin.

echo $PATH

From another post

gem uninstall eventmachine # (select all versions if prompted)
gem install eventmachine --platform ruby --user-install