I've upgraded to Debian buster

I’ve upgrade to Debian Buster (latest stable), and now nothing works. :frowning:

ruby was upgraded to 2.5

ruby --version
ruby 2.5.5p157 (2019-03-15 revision 67260) [x86_64-linux-gnu]

I’ve cleared out my gems directory to see if I could reinstall from scratch all here’s what I get

gem install jekyll bundler
Fetching em-websocket-0.5.1.gem
Fetching concurrent-ruby-1.1.5.gem
Fetching eventmachine-1.2.7.gem
Fetching public_suffix-3.1.1.gem
Fetching i18n-0.9.5.gem
Fetching addressable-2.6.0.gem
Fetching http_parser.rb-0.6.0.gem
Fetching colorator-1.1.0.gem
Fetching ffi-1.11.1.gem
Fetching rb-inotify-0.10.0.gem
Fetching rb-fsevent-0.10.3.gem
Fetching sass-listen-4.0.0.gem
Fetching sass-3.7.4.gem
Fetching jekyll-sass-converter-1.5.2.gem
Fetching ruby_dep-1.5.0.gem
Fetching listen-3.1.5.gem
Fetching jekyll-watch-2.2.1.gem
Fetching kramdown-1.17.0.gem
Fetching liquid-4.0.3.gem
Fetching mercenary-0.3.6.gem
Fetching forwardable-extended-2.6.0.gem
Fetching pathutil-0.16.2.gem
Fetching rouge-3.6.0.gem
Fetching safe_yaml-1.0.5.gem
Fetching jekyll-3.8.6.gem
ERROR:  While executing gem ... (ArgumentError)
    unknown keywords: permitted_classes, permitted_symbols

bummer, any ideas? (I really don’t want to go back to Stretch)

Has no one else tried installing jekyll in buster (or sid, previously) ?

Sorry for your long wait, this forum moves pretty slow. Did you ever get it worked out?

I’ve got no experience with debian, but it shouldn’t really matter. That error looks to me like one of jekyll’s dependencies is missing, or that something else went wrong with the installation process. I’d recommend uninstalling Ruby, using rbenv to manage your ruby version, and follow the install process again.

so here’s an interesting development.
I did a clean install today of debian buster
then followed the install instructions at https://terminaladdict.com/linux/jekyll/bash/development/2018/10/17/Jekyll-Getting-Started.html

Everything worked … so it seems, that things are broken in the upgrade process.