Installing themes requires install of outdated gems?

hi jekyll land,

i’m new to jekyll (and ruby), i’ve set it up locally on a debian machine to build a website that i’ll then push to a vps.

the problems i keep encountering is that after i download a theme (eg a zip from github) to set up my site, they often have dependency problems and wont run. i often get messages like this when i try to run bundle install in the theme dir:

"Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    bundler (~> 1.15)

  Current Bundler version:
    bundler (2.0.2)
This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running `gem install bundler`?

Could not find gem 'bundler (~> 1.15)' in any of the relevant sources:
  the local ruby installation"

and if i eg install the older bundler, then i end up with tons of duplicated gems, because the older versions are also added.

i had this happen on a few older themes so i thought they were broken, but then i just tried with the textlog theme which is not very old ( it also happened with the hack-css theme. the gemfile.lock of hack-css declares that it was bundled with bundler 1.13.x. does that mean that the only way to use that theme is to downgrade bundler (+all dependencies)?

it’s got me thinking that it’s me going about things the wrong way. i’m able to set up a site correctly with the minima and jekyll-now and minimal-mistakes themes, by following the jekyll tutorials. but i didn’t want to go with any of those.

and if different themes require different versions of lots of gems, it seems like it would make changing themes a difficult business.

if anyone can enlighten me a little about any of this, i’d be grateful.


1 Like

It is a pity that nobody has picked this up. I am new to Jekyll and ruby and tonight runs onto the same boat as yours. I am also wondering how does the Jekyll theme dev work? If for using a older theme runs with older gem packages I will have to downgrade the whole environment to be like that, I so do not understand this.
This is 2021, if anyone experienced picks this up please let us have a clue. Many thanks.

Keep using Bundler 2

Rather delete Gemfile.lock which is the thing that sets the Bundler 1 version

And then when you do Bundler install you’ll get a new lockfile

1 Like

Thanks let me try that tonight to see how it goes. Another thing is I saw that the original package was built with Jekyll 3.0.* not 4.2 which I’m having now. I will let you guys know about the outcomes.

Many thanks for watching guys. I am using this theme East by Aspire Themes

The make it running,

  1. delete Gemfile.lock


bundle install


Deprecation: You appear to have pagination turned on, but you haven't included the `jekyll-paginate` gem. Ensure you have `plugins: [jekyll-paginate]` in your configuration file.

  1. fix the deprecated pagination issue, will look into again in the future if it runs into further issue

2.1 add in _config.yml file with

# don't need to as the original config included this


- jekyll-paginate

paginate: 10

2.2 add in Gemfile file with

group :jekyll_plugins do

gem "jekyll-paginate"


  1. in Terminal try:

bundle install

got following. p.s. I am in a newly setup macOS on Apple Silicon

/Users/xxxxx/.gem/ruby/3.0.0/gems/jekyll-4.2.0/lib/jekyll/commands/serve/servlet.rb:3:in `require': cannot load such file -- webrick (LoadError)

  1. add webrick to bundle (in this theme build?)

bundle add webrick

  1. finally rebuild with success!

bundle install

bundle exec jekyll serve


Now published on Github Pages: Revive old Jekyll theme to version 4.2 running on macOS Big Sur with Apple Silicon

1 Like