How to disable the Sass cache?

I’m getting a lot of unnecessary rebuilds with messages like this:

Regenerating: 27 file(s) changed at 2022-10-25 04:04:46
                    .sass-cache/2637bfa8a21d3df1a930cd351dfa9f8256a9045f/animations.scssc
                    .sass-cache/2637bfa8a21d3df1a930cd351dfa9f8256a9045f/borders.scssc
                    .sass-cache/2637bfa8a21d3df1a930cd351dfa9f8256a9045f/box-shadow.scssc
                    .sass-cache/2637bfa8a21d3df1a930cd351dfa9f8256a9045f/colors.scssc
                    .sass-cache/2637bfa8a21d3df1a930cd351dfa9f8256a9045f/details.scssc
                    .sass-cache/2637bfa8a21d3df1a930cd351dfa9f8256a9045f/flexbox.scssc
                    .sass-cache/2637bfa8a21d3df1a930cd351dfa9f8256a9045f/layout.scssc
                    .sass-cache/2637bfa8a21d3df1a930cd351dfa9f8256a9045f/margin.scssc
                    .sass-cache/2637bfa8a21d3df1a930cd351dfa9f8256a9045f/padding.scssc
                    .sass-cache/2637bfa8a21d3df1a930cd351dfa9f8256a9045f/typography.scssc
                    .sass-cache/2637bfa8a21d3df1a930cd351dfa9f8256a9045f/visibility-display.scssc
                    .sass-cache/2bc7c02a7cb5ec18e29e9cd299ef93cbda1c4cfb/columns.scssc
                    .sass-cache/2bc7c02a7cb5ec18e29e9cd299ef93cbda1c4cfb/container.scssc
                    .sass-cache/2bc7c02a7cb5ec18e29e9cd299ef93cbda1c4cfb/grid-offset.scssc
                    .sass-cache/2bc7c02a7cb5ec18e29e9cd299ef93cbda1c4cfb/grid.scssc
                    .sass-cache/55d7553e6758ef36892ab333c6f39b6d2fab269d/index.scssc
                    .sass-cache/5b2d717ec111d5fa2c1c2baa42a108ff202fc3a0/component-detail.scssc
                    .sass-cache/5b2d717ec111d5fa2c1c2baa42a108ff202fc3a0/components-index.scssc
                    .sass-cache/5dc5d4005ce27f9aa6e90e95142ba2872e1b1c5b/index.scssc
                    .sass-cache/7060fc23f5b8c3b3b7b9357e701364f393aa4abe/blob-csv.scssc
                    .sass-cache/7060fc23f5b8c3b3b7b9357e701364f393aa4abe/code.scssc
                    .sass-cache/7060fc23f5b8c3b3b7b9357e701364f393aa4abe/headings.scssc
                    .sass-cache/7060fc23f5b8c3b3b7b9357e701364f393aa4abe/images.scssc
                    .sass-cache/7060fc23f5b8c3b3b7b9357e701364f393aa4abe/lists.scssc
                    .sass-cache/7060fc23f5b8c3b3b7b9357e701364f393aa4abe/markdown-body.scssc
                    .sass-cache/7060fc23f5b8c3b3b7b9357e701364f393aa4abe/tables.scssc
                    .sass-cache/a903e8d99a1f0bf83d3f1cbe86e77bb0bfd7113b/index.scssc
                    ...done in 71.234561491 seconds.

It’s a bit random and it happens when literally nothing in my source files has changed. I did not have this problem prior to changing my Gemfile to not use the github-pages gem.

I thought I could disable the cache because I have seen some mentions of a _config.yml declaration like this:

sass:
  cache: false

Here for example: Incorrect Documentation (cache: false) · Issue #36 · jekyll/jekyll-sass-converter · GitHub

Yet I cannot find any actual documentation of this setting and it’s not working for me.

I’m using Jekyll 3.9.2 (planning to upgrade soon).