Failed to build gem native extension

can anyone help me with this error, I am on windows

You need to install the Development Kit to install C-extensions for Ruby on Windows
To download the supported Kit version for your Ruby version, refer to the
WHICH DEVELOPMENT KIT? section in this page

I did install Devkit

@gamer if you’re okay messing with DevKit installation on your PC but it didn’t solve your problem - would you be OK to give it a try to install Docker on your PC?

I couldn’t help myself but suggest every time I see issues running Jekyll natively on OSX or Windows to switch to use Docker instead. Saves time and hair - 100% validated and guaranteed.

If you decide to, I would be more than happy to help you get started up & running quickly without those pesky DevKit and building native extensions issues.


I solved it.
thanks for replying tho and I didn’t reply before because my account was new and I was not able to reply that’s why it took so long to reply


mind sharing how you solved the issue?

I had spaces in the name of my main folder that’s why that issue was occuring, later i created a new folder with no space and it worked.

I’m running into the same issue. I downloaded the devkit, ran it, but I don’t know if I was supposed to do anything else. Do I put the devkit in my path? Do I run a file there?

So I found the instructions about what to run in terms of the dev kit, but it has not helped at all. When I try to install Jekyll I do see: Temporarily enhancing PATH to include DevKit... but it didn’t help

do you have spaces in any folder in which you’re trying to install it?