Error when using apostrophe marks


In the front matter section, if I set the title and description as follows:

layout: post
author: "Anang Putra Setiyawan, Ni Made Ras Amanda Gelgel, I Gusti Agung Alit Suryawati"
description: "Alternative Economic Discourse in the Film 'The Take'. Film is..."
categories: communication
tags: Not Available

I encounter an error like the following:

Error: YAML Exception reading C:/jurnal/_posts/komunikasi/ (<unknown>): did not find expected key while parsing a block mapping at line 2 column 1

It seems that the issue lies in the apostrophe in the title?? (and possibly in the description section?). Is there a way to still use quotation marks in the front matter? In some cases, we need apostrophe marks in the title.

Thank you.

have you removed all the single quotes to see if that really is the issue?

did you try it without the double quotes?

I would simplify everything (no single or double quotes) till it works and then go forward until you know exactly what caused it. Single quotes should be ok one way or another.

I tried all of your strings above and they all worked fine, no errors.

Are you sure this is the correct file?

I tried all of your strings above and they all worked fine, no errors.

Are you sure this is the correct file?

yes , its the correct file . but that just sample file

but using &quot regeneration success without any issue,…like this

line 7 column 7 because i have double : so i guess the issue solved

im converting article from different cms into jekyll using script ,some of article use apostrophe in its title and it seems causing error

certainly can’t have an extra colon in there as that is the separator between key and value, I think you can escape it somehow or maybe it works when quoted.

Keep in mind the normal apostrophe on the key board is ’ and does not curve one way or the other like this does:

I think that is a curly quote and those come in single and double and I have seen those cause issues, I avoid them.

Are you sure the file you are working on is utf-8 encoded? I can’t remember if that still causes issues if it is not but my guess is it needs to be utf-8. Since you are converting the content somehow maybe the thing exporting the files is not encoding them properly.

i’m not quite familiar with jekyll but is there’s section in config.yml or plugin that will auto convert character into html entities

my current config.yml as follow

# Site settings
title:          tale
description:    "Minimal Jekyll theme for storytellers"
#baseurl:        "/tale"
url:            ""

# Google Analytics
google_analytics: UA—XXXXXXXX-X

# Author
  name:         Chester How

# Build settings
markdown:       kramdown
  - _pages

# Assets
  sass_dir:     _sass
  style:        compressed

# Gems
  - jekyll-feed
  - jekyll-paginate
  - jekyll-seo-tag
  # - jemoji #Uncomment this to allow emoji in your post

# Permalinks
permalink:      /:categories/:title
paginate:       5

# Excludes
exclude: [ Gemfile, Gemfile.lock, tale.gemspec ]

# Disqus (Set to your disqus id)
disqus:         jekyll-tale

not that I know of. Which characters? you could probably use find and replace in your code editor if you know which character the problem is.

there’s a lot of them (‘,“,“, etc) but to be honest im not sure which one… since im converting in bulk

maybe you’re right , maybe the script im using doesn’t use utf-8…i need to double check it

if you are using VS Code as your editor it will tell you the encoding of the file at the bottom - at least I think it does on its own, I don’t remember telling it to do this for me: