Bundle install issues for Catalina

Thanks I tried that with no success had it installed already. This is what I’m getting when I try to bundle install

stahl@2usmstahl blog % bundle exec jekyll serve
Could not find http_parser.rb-0.6.0 in any of the sources
Run bundle install to install missing gems.
stahl@2usmstahl blog % bundle install
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java.
Fetching gem metadata from https://rubygems.org/
Using public_suffix 3.0.3
Using addressable 2.5.2
Using bundler 1.17.2
Using colorator 1.1.0
Using concurrent-ruby 1.0.5
Using eventmachine 1.2.7
Fetching http_parser.rb 0.6.0
Installing http_parser.rb 0.6.0 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory: /Users/stahl/Dropbox/Web
/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/bin/ruby -I
/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0 -r ./siteconf20200828-36630-1hsvaxb.rb extconf.rb
creating Makefile

current directory: /Users/stahl/Dropbox/Web
make “DESTDIR=” clean

current directory: /Users/stahl/Dropbox/Web
make “DESTDIR=”
compiling ruby_http_parser.c
clang: error: no such file or directory:
make: *** [ruby_http_parser.o] Error 1

make failed, exit code 2

Gem files will remain installed in /Users/stahl/Dropbox/Web
Programming/Bootcamp/blog/vendor/bundle/ruby/2.6.0/gems/http_parser.rb-0.6.0 for inspection.
Results logged to /Users/stahl/Dropbox/Web

An error occurred while installing http_parser.rb (0.6.0), and Bundler cannot continue.
Make sure that gem install http_parser.rb -v '0.6.0' --source 'https://rubygems.org/' succeeds before bundling.

In Gemfile:
jekyll-feed was resolved to 0.11.0, which depends on
jekyll was resolved to 3.7.4, which depends on
em-websocket was resolved to 0.5.1, which depends on
stahl@2usmstahl blog %

Sorry to hear that installing libffi didn’t work! Do you see this issue even when creating a new test website or is it specific to your existing blog? Also, is there’s a space in the path to your blog (there seems to be a directory called “Web Programming”)?

No I haven’t tried testing a new blog. The funny thing is I did get this to work 2x but then it didn’t work again. I think that is just how this forum copied over my terminal notes

Good information thanks for sharing