Jekyll instructions fail


#1

Running on Ubuntu 14.04, I first tried to follow the “Get up and running in seconds.” instructions at http://jekyllrb.com/
which of course failed at step (1) “gem install jekyll bundler”. By googling I found the long thread at https://github.com/jekyll/jekyll/issues/5719
and learned those instructions are incomplete - the real “Quick Start Instructions” webpage (which was not
given as a link on the home page) indicated that an install of ruby-all-dev was required. So did that.
Then “gem install jekyll bundler” seemed to run ok - lots of output, no apparent error messages.

So, an hour later, on to step (2). Running “jekyll new blog” gave

/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
WARNING: Could not read configuration. Using defaults (and options).
    No such file or directory - new/_config.yml
Building site: new -> blog
/usr/lib/ruby/vendor_ruby/jekyll/site.rb:126:in `chdir': No such file or directory - /var/www/html/HIKES/TRAILMAP/new/ (Errno::ENOENT)
    from /usr/lib/ruby/vendor_ruby/jekyll/site.rb:126:in `read_directories'
    from /usr/lib/ruby/vendor_ruby/jekyll/site.rb:98:in `read'
    from /usr/lib/ruby/vendor_ruby/jekyll/site.rb:38:in `process'
    from /usr/bin/jekyll:250:in `<main>'

No apparent fatal error, just “warning” But step (3) “cd blog” gave “No such file or directory”. Also tried creating directory blog manually,
entering and running “jekyll new . --force” - gave error
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in require': iconv will be deprecated in the future, use String#encode instead. /usr/bin/jekyll:137:in': invalid option: --force (OptionParser::InvalidOption)

So giving up


#2

Looks like you’re using Ruby 1.9.1

According to the Jekyll installation docs you need 2+

Ruby version 2.0 or above, including all development headers


#3

Thanks for the explanation