# "jekyll 3.6.2 | Error: Permission denied @ rb\_sysopen" after Firebase deploy

**URL:** <https://talk.jekyllrb.com/t/jekyll-3-6-2-error-permission-denied-rb-sysopen-after-firebase-deploy/1134>\
**Category:** Help\
**Created:** [October 30, 2017, 11:17am UTC](https://talk.jekyllrb.com/t/jekyll-3-6-2-error-permission-denied-rb-sysopen-after-firebase-deploy/1134 "2017-10-30T11:17:20Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![liu-kang](https://avatars.discourse-cdn.com/v4/letter/l/e56c9b/32.png) [@liu-kang](https://talk.jekyllrb.com/u/liu-kang)\
**Post date:** [October 30, 2017, 11:17am UTC](https://talk.jekyllrb.com/t/jekyll-3-6-2-error-permission-denied-rb-sysopen-after-firebase-deploy/1134/1 "2017-10-30T11:17:20Z")

</div>

I have a blog hosted with Firebase. Using [RubyInstaller for Windows](https://rubyinstaller.org/) - sometimes after deploying to Firebase, it’s no longer possible to build the jekyll website due `Permission denied @ rb_sysopen`

It seems this just randomly occurs after working some hours, see log below (just after a successful build and deploy):

```
C:\Users\Liukang\Google Drive\MY-BLOG\liukang_blog>jekyll build
Configuration file: C:/Users/Liukang/Google Drive/MY-BLOG/liukang_blog/_config.yml
            Source: C:/Users/Liukang/Google Drive/MY-BLOG/liukang_blog
       Destination: C:/Users/Liukang/Google Drive/MY-BLOG/liukang_blog/_site
 Incremental build: disabled. Enable with --incremental
      Generating...
                    done in 0.598 seconds.
 Auto-regeneration: disabled. Use --watch to enable.

C:\Users\Liukang\Google Drive\MY-BLOG\liukang_blog>firebase deploy
1

=== Deploying to 'Liukang-blog'...

i deploying hosting
i hosting: preparing _site directory for upload...
+ hosting: 9 files uploaded successfully

+ Deploy complete!

C:\Users\Liukang\Google Drive\MY-BLOG\liukang_blog>jekyll build
Configuration file: C:/Users/Liukang/Google Drive/MY-BLOG/liukang_blog/_config.yml
            Source: C:/Users/Liukang/Google Drive/MY-BLOG/liukang_blog
       Destination: C:/Users/Liukang/Google Drive/MY-BLOG/liukang_blog/_site
 Incremental build: disabled. Enable with --incremental
      Generating...
                    done in 0.573 seconds.
 Auto-regeneration: disabled. Use --watch to enable.

C:\Users\Liukang\Google Drive\MY-BLOG\liukang_blog>firebase deploy
1

=== Deploying to 'Liukang-blog'...

i deploying hosting
i hosting: preparing _site directory for upload...
+ hosting: 9 files uploaded successfully

+ Deploy complete!

C:\Users\Liukang\Google Drive\MY-BLOG\liukang_blog>jekyll build
Configuration file: C:/Users/Liukang/Google Drive/MY-BLOG/liukang_blog/_config.yml
            Source: C:/Users/Liukang/Google Drive/MY-BLOG/BLOG/liukang_blog
       Destination: C:/Users/Liukang/Google Drive/MY-BLOG/BLOG/liukang_blog/_site
 Incremental build: disabled. Enable with --incremental
      Generating...
                    done in 0.581 seconds.
 Auto-regeneration: disabled. Use --watch to enable.

C:\Users\Liukang\Google Drive\MY-BLOG\liukang_blog>firebase deploy
1

=== Deploying to 'Liukang-blog'...

i deploying hosting
i hosting: preparing _site directory for upload...
+ hosting: 9 files uploaded successfully

+ Deploy complete!

C:\Users\Liukang\Google Drive\MY-BLOG\liukang_blog>jekyll build
Configuration file: C:/Users/Liukang/Google Drive/MY-BLOG/liukang_blog/_config.yml
            Source: C:/Users/Liukang/Google Drive/MY-BLOG/liukang_blog
       Destination: C:/Users/Liukang/Google Drive/MY-BLOG/liukang_blog/_site
 Incremental build: disabled. Enable with --incremental
      Generating...
jekyll 3.6.2 | Error: Permission denied @ rb_sysopen - C:/Users/Liukang/Google Drive/MY-BLOG/liukang_blog/firebase-debug.log

```

I can’t open _firebase-debug.log_ or delete it. I can “solve” the problem by shutting down the computer, which is frustrating.

Is this caused by not having correct file permission - if so, how do I setup the correct permission, so this doesn’t happen again?
