What is this error that I am receiving?


I have no clue what is going on? I’m starting a new project and getting the following message in terminal:

-bash: /Users/christians/.rvm/scripts/initialize: No such file or directory
-bash: /Users/christians/.rvm/scripts/hook: No such file or directory


Deprecation: The 'gems' configuration option has been renamed to 'plugins'. Please update your config file accordingly.


E, [2017-06-29T09:20:48.907911 #1072] ERROR -- : fsevent: running worker failed: wrong number of arguments (given 2, expected 1):/usr/local/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/base.rb:41:in `block (2 levels) in configure'
/usr/local/lib/ruby/gems/2.3.0/gems/rb-fsevent-0.10.1/lib/rb-fsevent/fsevent.rb:75:in `run'
/usr/local/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/darwin.rb:68:in `_run_worker'
/usr/local/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/darwin.rb:52:in `_run'
/usr/local/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/base.rb:78:in `block in start'
/usr/local/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/internals/thread_pool.rb:6:in `block in add' called from: /usr/local/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/darwin.rb:67:in `_run_worker'
/usr/local/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/darwin.rb:52:in `_run'
/usr/local/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/adapter/base.rb:78:in `block in start'
/usr/local/lib/ruby/gems/2.3.0/gems/listen-3.0.8/lib/listen/internals/thread_pool.rb:6:in `block in add'

Liquid error: wrong number of arguments

Both messages have nothing in common, the first is a change introduced in Jekyll 3.5.0, from now on you write:

  - jekyll-feed
  - jekyll-sitemap
  - jemoji

For fs-event, check this issue : https://github.com/jekyll/jekyll/issues/6189


Okay—there’s no need for me to include:
-jemoji , right?


Correct! Simply rename the gems key in /faculty-one/_config.yml to plugins

Liquid Exception: 1 is not a symbol nor a string in sitemap.xml