Odd Dependency Error while jekyll serve


#1

Getting weird error while trying to jekyll serve.

Dependency Error: Yikes! It looks like you don't have jemoji or one of 
its dependencies installed. In order to use Jekyll as currently configured, 
you'll need to install this gem. The full error message from Ruby is: 'Unable 
to activate activesupport-4.2.7.1, because json-2.0.3 conflicts with 
json (>= 1.7.7, ~> 1.7)' If you run into trouble, you can find helpful resources 
at https://jekyllrb.com/help/! 

I’ve uninstalled and reinstalled but can’t figure the problem out. I’ve done a gem update and the actual versions I have are below:

*** LOCAL GEMS ***

activesupport (5.0.1, 4.2.7.1)
addressable (2.5.0)
bigdecimal (default: 1.3.0)
bundle (0.0.1)
bundler (1.14.3)
colorator (1.1.0)
colored (1.2)
concurrent-ruby (1.0.4)
did_you_mean (1.1.0)
ethon (0.10.1)
ffi (1.9.17)
forwardable-extended (2.6.0)
gemoji (3.0.0)
html-pipeline (2.5.0)
html-proofer (3.4.0)
i18n (0.8.0)
io-console (default: 0.4.6)
jekyll (3.4.0)
jekyll-paginate (1.1.0)
jekyll-sass-converter (1.5.0)
jekyll-watch (1.5.0)
jemoji (0.8.0)
json (2.0.3, default: 2.0.2, 1.8.6)
kramdown (1.13.2)
liquid (4.0.0, 3.0.6)
listen (3.1.5, 3.0.8)
mercenary (0.3.6)
mini_portile2 (2.1.0)
minitest (5.10.1)
net-telnet (0.1.1)
nokogiri (1.7.0.1)
openssl (2.0.3, default: 2.0.2)
parallel (1.10.0)
pathutil (0.14.0)
power_assert (1.0.1)
psych (default: 2.2.2)
public_suffix (2.0.5)
rake (12.0.0)
rb-fsevent (0.9.8)
rb-inotify (0.9.8)
rdoc (default: 5.0.0)
rouge (2.0.7, 1.11.1)
ruby_dep (1.5.0)
safe_yaml (1.0.4)
sass (3.4.23)
test-unit (3.2.3)
thread_safe (0.3.5)
typhoeus (0.8.0)
tzinfo (1.2.2)
xmlrpc (0.2.1)
yell (2.0.7)


#2

I’m no expert at this, but it looks like it is telling you that your version of json 2.03 is not compatible with what something else wants - json 1.7.x.

I think I would try to install json 1.7.7 and maybe uninstall the other one?


#3

Add the following to your Gemfile

group :jekyll_plugins do
  gem "jemoji", "~> 0.8"
end

and run

bundle exec jekyll serve

A


#4

I tried. When I go to fetch the gem, I get several hundred errors during the build.

ERROR:  Error installing json:
ERROR: Failed to build gem native extension.

/Users/getChester/.rbenv/versions/2.4.0/include/ruby-2.4.0/ruby/ruby.h:2158:12: note: expanded from macro 'rb_scan_args_count_end'
    ((vari)/(!fmt[ofs] || rb_scan_args_bad_format(fmt)))
           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
67 warnings and 3 errors generated.
make: *** [generator.o] Error 1