Jekyll is not compiling scss files


#1

Here is the preview of the image

Public github repo: https://github.com/imbyurhan/imbyurhan.github.io


#2

I think you need to add blank front matter to top of /assets/css/main.scss so Jekyll knows to process it as Sass.

---
---

@charset 'UTF-8';

// 1. Configuration and helpers
@import '1-helpers/mixins';
@import '1-helpers/variables';
@import '2-helpers/normalize';

// 2. Base stuff
@import '2-basics/base';
@import '2-basics/fonts';
...

#3

Yes but when I add front matter I get this error.

I have not studied or wrote before scss, after reviewing a some code I am started to coding. I don’t know if there I have a mistakes?

This style at header.scss is written for test but it’s not working.


#4

Those warnings are letting you know Sass can’t find the .scss partials in your main.scss file. I’d look at all the lines that start with @import as those are the problem.

Each one of those lines are telling the Sass gem to pull in another .scss partial, but it can’t locate them because it’s looking for them in _sass folder.

Move everything except main.scss into <your site root>/_sass and that should solve your problem. You currently have all the partials in assets/css/, which isn’t where Jekyll is expecting them. There are settings to change it if you don’t want to use the default _sass folder.


#5

Thank you very much. Its working now. I change the sass_dir to assets/css and find one more mistake at importing the normalize css.

:grinning: