Jekyll installation, wrong number of arguments


#1

Hi,
I have trouble installing jekyll on fedora. I created an issue on stack overflow but then found this discourse.

I am running Fedora 28. I have all the dependencies mentioned on installation page.

ruby -v
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux]

gem -v
2.5.2

bundle -v
Bundler version 1.16.1

When I try to install Jekyll, I am getting this -

gem install jekyll
ERROR:  While executing gem ... (ArgumentError)
    wrong number of arguments (given 1, expected 0)

Running as root doesn’t help either. When I run backtrace,

gem install jekyll --backtrace
ERROR:  While executing gem ... (ArgumentError)
    wrong number of arguments (given 1, expected 0)
    /usr/local/share/ruby/site_ruby/rubygems/core_ext/kernel_require.rb:47:in `require'
    /usr/local/share/ruby/site_ruby/rubygems/installer.rb:162:in `initialize'
    /usr/local/share/ruby/site_ruby/rubygems/installer.rb:104:in `new'
    /usr/local/share/ruby/site_ruby/rubygems/installer.rb:104:in `at'
    /usr/local/share/ruby/site_ruby/rubygems/resolver/specification.rb:93:in `install'
    /usr/local/share/ruby/site_ruby/rubygems/request_set.rb:166:in `block in install'
    /usr/local/share/ruby/site_ruby/rubygems/request_set.rb:156:in `each'
    /usr/local/share/ruby/site_ruby/rubygems/request_set.rb:156:in `install'
    /usr/local/share/ruby/site_ruby/rubygems/commands/install_command.rb:250:in `install_gem'
    /usr/local/share/ruby/site_ruby/rubygems/commands/install_command.rb:300:in `block in install_gems'
    /usr/local/share/ruby/site_ruby/rubygems/commands/install_command.rb:296:in `each'
    /usr/local/share/ruby/site_ruby/rubygems/commands/install_command.rb:296:in `install_gems'
    /usr/local/share/ruby/site_ruby/rubygems/commands/install_command.rb:203:in `execute'
    /usr/local/share/ruby/site_ruby/rubygems/command.rb:308:in `invoke_with_build_args'
    /usr/local/share/ruby/site_ruby/rubygems/command_manager.rb:169:in `process_args'
    /usr/local/share/ruby/site_ruby/rubygems/command_manager.rb:139:in `run'
    /usr/local/share/ruby/site_ruby/rubygems/gem_runner.rb:55:in `run'
    /usr/bin/gem:21:in `<main>'

#2

I guess the ruby version was the problem. Once I installed ruby 2.4 using https://rvm.io/ installation was successful