Jekyll 3.6.2 | Error: superclass mismatch for class Cipher


#1

ruby 2.4.2p198 (2017-09-14 revision 59899) [x86_64-linux]
Bundler version 1.16.0

$ bundle exec jekyll server                   (gh-pages✱) 
/usr/lib/ruby/2.4.0/json/version.rb:4: warning: already initialized constant JSON::VERSION
/home/mkfoy/.gem/ruby/2.4.0/gems/json-2.1.0/lib/json/version.rb:4: warning: previous definition of VERSION was here
/usr/lib/ruby/2.4.0/json/version.rb:5: warning: already initialized constant JSON::VERSION_ARRAY
/home/mkfoy/.gem/ruby/2.4.0/gems/json-2.1.0/lib/json/version.rb:5: warning: previous definition of VERSION_ARRAY was here
/usr/lib/ruby/2.4.0/json/version.rb:6: warning: already initialized constant JSON::VERSION_MAJOR
/home/mkfoy/.gem/ruby/2.4.0/gems/json-2.1.0/lib/json/version.rb:6: warning: previous definiti
.....................
.........................
/usr/lib/ruby/2.4.0/openssl/cipher.rb:64: warning: constant OpenSSL::Cipher::Cipher is deprecated
/usr/lib/ruby/2.4.0/openssl/cipher.rb:64: warning: constant OpenSSL::Cipher::Cipher is deprecated
jekyll 3.6.2 | Error:  superclass mismatch for class Cipher

this my Gemfile file

source "https://rubygems.org"

require 'json'
#gem 'json', '~> 2.0.0'
require 'open-uri'
versions = JSON.parse(open('https://pages.github.com/versions.json').read)
gem 'github-pages', versions['github-pages'], group: :jekyll_plugins

I don’t know how to solve the problem. can I help me?


#2

What if you follow default instructions for the Gemfile?