Heading not rendered


#1

Hi,

i am using jekyll and i have heading not being rendered.

I have attached an image that shows how ### and ##### are not translated to proper html tags; i can add that:

  1. the untranslated string is wrapped into a paragraph tag
  2. styles are not causing the problem, since i have wiped away _styles.scss and still the issue is here.

Here’s my kramdown section of config file:

kramdown:
auto_ids: true
footnote_nr: 1
entity_output: as_char
toc_levels: 1…6
enable_coderay: false

syntax_highlighter_opts:
ine_numbers:
line_numbers_start: 1
tab_width: 4
bold_every: 10
css: class

I don’t reasonably remember i have played with this anytime.

Thanks in advance for the help.

Bruno


#2

To render Markdown elements nested inside HTML tags, you need to set {::options parse_block_html="true" /} first:

{::options parse_block_html="true" /}
<div>
  ### Heading 3
  [lorem ipsum](http://foo.bar)
</div>
{::options parse_block_html="false" /}

This will render into:

<div>
  <h3>Heading 3</h3>
  <a href="http://foo.bar">lorem ipsum</a>
</div>

#3

Sorry, i ahve not been enough clear. The paragraph tag wrapping the heading is automatically inserted, my md file is very simple:

h1

stuff

h2

stuff

and down to h6. H3 and H5 are NOT correctly rendered :confused:

Sorry if i have not been enough clear. And thanks for help !


#4

I could not reproduce this at my end.
I suggest you update your gemset and try again (especially required if you’re using the plugins jekyll-mentions or jemoji)

$ bundle update

#5

Can you share the .md file in which you are facing the issue?