Deploy with jekyll-paginate-v2 fails


You’re welcome!
So are you using the updated hooks/post-receive I posted above or the one currently live in the official docs?


I’m using your script posted above.


Hey! New issue as of today. I’m making some changes after a couple months so naturally several gems need to be updated. I’m now encountering an error during deployment:

remote: bundler: failed to load command: jekyll (/home/diklein/.rvm/gems/ruby-2.4.2/bin/jekyll) remote: OptionParser::MissingArgument: missing argument: -d remote: /home/diklein/.rvm/gems/ruby-2.4.2/gems/mercenary-0.3.6/lib/mercenary/program.rb:31:ingo’ remote: /home/diklein/.rvm/gems/ruby-2.4.2/gems/mercenary-0.3.6/lib/mercenary.rb:19:in program' remote: /home/diklein/.rvm/gems/ruby-2.4.2/gems/jekyll-3.7.2/exe/jekyll:15:in<top (required)>‘ remote: /home/diklein/.rvm/gems/ruby-2.4.2/bin/jekyll:23:in load' remote: /home/diklein/.rvm/gems/ruby-2.4.2/bin/jekyll:23:in<top (required)>’


Are you using the same script for deployment…?
Are you able to manually run bundle exec jekyll build on a local site…?

Looks to me like something went wrong while you were updating the gems…


On my machine I see:

DKMBP:wedding tehdik$ bundle exec jekyll build Configuration file: /Users/tehdik/Dropbox/wedding/_config.yml Source: /Users/tehdik/Dropbox/wedding Destination: /Users/tehdik/Dropbox/wedding/_site Incremental build: disabled. Enable with --incremental Generating... Assets: Compression is ignored w/ SourceMaps done in 0.206 seconds. Auto-regeneration: disabled. Use --watch to enable.

I’m not using a script when I run locally. Only on the server. How can I properly update my gems on the server? Thanks again for your help.