Dependency Error for i18n


#1

On Friday, Jekyll was working fine but when I try to run “jekyll build” today, I get the following error:

Dependency Error: Yikes! It looks like you don’t have jekyll-responsive-image or one of its dependencies installed. In order to use Jekyll as currently configured, you’ll need to install this gem. The full error message from Ruby is: ‘Unable to activate jekyll-3.8.3, because i18n-1.1.0 conflicts with i18n (~> 0.7)’

I do have jekyll-responsive-image installed and everything was working fine last week. Looks like the issue is with dependency requirements for i18n, but I have no idea how to fix this. Any help would be appreciated.


#2

The recommended way to resolve this is:

  • Add jekyll-responsive-image to your Gemfile
    gem 'jekyll-responsive-image'
    
  • Activate Jekyll via Bundler: (gem bundler needs to be installed before hand)
    bundle exec jekyll build
    

#3

I was able to resolve this by uninstalling i18n version 1.1.0 as I already had a previous version which met the dependency requirements.