Custom CSS ignored on GH Project Page (but works on GH User Page!)

#1

I’m trying to override my theme’s CSS using this technique:

on my GH Project:

No matter where I put the two CSS rules I want to override (in _sass/cjauvin.scss after having @imported it in assets/css/style.scss, or directly there), they are not being used:

This is for a GH Project page, but strangely, when I test the same setup in my GH User page, it works. What do I do wrong? (it’s also working locally of course)

#2

this is very common - in a project your project name is part of the path. In your user page it is not. So you need to include the project name in all paths, usually this is done with baseurl as a site variable in the config file, then you prepend that to your urls. That way you can leave it blank if you don’t need it, or put something there if you do.

#3

That is exactly right, thanks a lot for your rapid answer! Setting the baseurl was indeed all that I needed to do.