Bad File Descriptor when using --livereload


#1

I’m running jekyll 3.7.3 on Windows 7, I’ve been getting

C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/eventmachine-1.2.5-x64-mingw32/lib/em/pure_ruby.rb:554:in `close': Bad file descriptor (Errno::EBADF)
        from C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/eventmachine-1.2.5-x64-mingw32/lib/em/pure_ruby.rb:554:in `block in run'
        from C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/eventmachine-1.2.5-x64-mingw32/lib/em/pure_ruby.rb:554:in `each'
        from C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/eventmachine-1.2.5-x64-mingw32/lib/em/pure_ruby.rb:554:in `ensure in run'
        from C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/eventmachine-1.2.5-x64-mingw32/lib/em/pure_ruby.rb:557:in `run'
        from C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/eventmachine-1.2.5-x64-mingw32/lib/em/pure_ruby.rb:144:in `run_machine'
        from C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/eventmachine-1.2.5-x64-mingw32/lib/eventmachine.rb:194:in `run'
        from C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/jekyll-3.7.3/lib/jekyll/commands/serve/live_reload_reactor.rb:45:in `block in start'

When trying to run the --livereload option with bundle exec jekyll serve and editing a file. I seem to think this was working fine a week ago, not sure if I maybe messed something up by updating, my gemfile adds support for wdm latest and em/pure_ruby.


#2

The issue could be due to:

EventMachine is not yet compatible with Ruby 2.4+ on Windows:


#3

Thank you! What a dumb mistake, you get kind of tired looking through all the readme files, I should have checked there first before updating ruby.

I just reinstalled ruby 2.3.3, I should have checked before updating.