Auto-regeneration not working even with --watch used


#1

When running any of these commands:

bundle exec jekyll serve
bundle exec jekyll serve --watch
bundle exec jekyll serve --force_polling

I get:

Auto-regeneration: disabled. Use --watch to enable.

and I can’t see local updates until I stop (ctrl+c) and run the command again!

jekyll version (jekyll -v) gives jekyll 3.4.3 which is the same as in my gemfile

What should I do?


#2

The problem is in the plugin jekyll-admin v0.4.1 it disables --watch internally! So I just removed it